Troubleshooting my Overland Connection to Open Humans

Anybody here using the Overland connector to OH? I’m troubleshooting my connection, I’ve got 6568 locations queued by they aren’t being received by OH as far as I can tell. I’ve got my settings set identically to what’s recommended here:

But when I run the notebook @gedankenstuecke wrote, I get this error:

On my app I don’t get an error message, and from the timer on this page it looks like my data was “last sent” just a few seconds ago. But the queue persists…


Hey @Agaricus,
the error in the notebook is probably because you don’t have any data saved in your account yet given the increasing number of queued data points. Could you have a look at and tell me if you have any Overland data files listed on that page?

The not-sending of batches seems very weird. Could you maybe also show us a screenshot of your settings-tab in the Overland-App (and redact the endpoint-URL if fully visible)? Otherwise a simple test could be to press the “Send now” button in the App and see if the queue shrinks by as many data points as is given for the batch size.


Step one of fixing the problem accomplished:

Although my server setting appeared to be correct when I looked at the settings panel on the Overland app, when I erased the server address and recopied it from the Open Humans settings instructions my Overland data began to upload. Now it is stuck here:

Glad to hear that you got Overland to synchronize the data! The error in this case seems to be due to what the default date (year + month) it uses for the visualization. It tries to grab your data for June 2019, in which you didn’t have Overland yet, so it fails to get any data. Would it be useful for me to just change this to always use the current month?

Progress! I changed the date to Month <- ‘2020-06’ and it plotted a map, but then it got stuck at Step 10 with this error message: Warning message:
“Removed 17434 rows containing missing values (geom_point).”